Issues logging into Billing Webapp

Incident Report for Smokeball United Kingdom

Resolved

This incident has been resolved.
Posted Apr 16, 2025 - 15:25 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 16, 2025 - 12:57 BST

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 16, 2025 - 12:27 BST

Investigating

Some firms are experiencing difficulty logging into Smokeball webapp. Our team has identified an issue and are working to resolve it with priority.
Posted Apr 16, 2025 - 12:14 BST
This incident affected: Smokeball Billing.